Windows application (first impressions)
log in

Advanced search

Message boards : Windows : Windows application (first impressions)

Author Message
Profile valterc
Project administrator
Project tester
Send message
Joined: 30 Oct 13
Posts: 320
Credit: 16,284,763
RAC: 4,149
Italy
Message 83 - Posted: 19 Dec 2013, 11:17:12 UTC
Last modified: 20 Dec 2013, 10:15:25 UTC

I'm just crunching my first workunit:
- progress bar is alive (although moving slowly, by design).
- memory occupation is low, ranging from 10 to 20 Mb.
- it writes the checkpoint file, but if you show the task properties from the boinc client then 'CPU time at last checkpoint' is not defined. I won't try to suspend and resume it by now...
- I got a 32 bit executable (even if I run a x64 host), but this must be solved server side.

[edit] today I got a correct x64 application

Profile NadirS [SSC11]
Project developer
Project tester
Project scientist
Send message
Joined: 20 Nov 13
Posts: 13
Credit: 133,573
RAC: 0
Italy
Message 88 - Posted: 19 Dec 2013, 13:43:10 UTC

For me suspend does not suspend the task. Which could be the problem?

Profile FrancescoAsnicar [SSC11]
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 14 Nov 13
Posts: 50
Credit: 6,654,411
RAC: 5,326
Italy
Message 89 - Posted: 19 Dec 2013, 13:45:06 UTC - in response to Message 83.

Also on Mac OSX the suspend does not suspend the task... In the BOINC API there is nothing about suspension code-side.

Profile valterc
Project administrator
Project tester
Send message
Joined: 30 Oct 13
Posts: 320
Credit: 16,284,763
RAC: 4,149
Italy
Message 101 - Posted: 19 Dec 2013, 18:46:40 UTC - in response to Message 89.

Also on Mac OSX the suspend does not suspend the task... In the BOINC API there is nothing about suspension code-side.

maybe this: int boinc_time_to_checkpoint();

Profile danicampa90
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 12 Nov 13
Posts: 28
Credit: 552
RAC: 0
Italy
Message 104 - Posted: 19 Dec 2013, 19:16:44 UTC

Also on my pc (linux x64) it does not suspend.
If I remember correctly some time ago the suspension was working correctly...
I also suggest to check if the issue of suspension in not related to the other problem we are having (the different outputs between runs, related to checkpoints).


WRT the fact that you got an x86 application on a x64 host:
- it happened to me some time ago, but then it disappeared by its own after a few workunits. I thougt that this was a boinc synchronization glitch (I did just upload the pokemon to the server).
- is it still running the x86 version? (Did time solve the problem, or it is still persisting)?
- the two versions were uploaded and registered correctly (with update_apps). I thougth that boinc would take care of the rest, and distribute them accordingly to the architecture. Do I need to write some additional configuration for that?

Profile FrancescoAsnicar [SSC11]
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 14 Nov 13
Posts: 50
Credit: 6,654,411
RAC: 5,326
Italy
Message 105 - Posted: 19 Dec 2013, 19:18:43 UTC - in response to Message 101.
Last modified: 19 Dec 2013, 19:20:45 UTC

We used

int boinc_time_to_checkpoint();
when we write the checkpoint file.
So I guess that is not related to the suspend issue.

Profile [PUGLIA] Francesco
Send message
Joined: 20 Dec 13
Posts: 1
Credit: 27,239
RAC: 0
Italy
Message 114 - Posted: 20 Dec 2013, 10:36:01 UTC

1st WU failed to start on an old PIII with Win32K - 384MBRam: http://gene.disi.unitn.it/test/result.php?resultid=33778 same error as Rosetta and other projects.

20 WU on an AMD A4-5000 are running (and showing progress-bar) with an estimated time of 50min to complete: http://gene.disi.unitn.it/test/show_host_detail.php?hostid=32


Post to thread

Message boards : Windows : Windows application (first impressions)


Main page · Your account · Message boards


Copyright © 2017 CNR-TN & UniTN