Resource Share Problem
log in

Advanced search

Message boards : Number crunching : Resource Share Problem

Author Message
Bryn Mawr
Send message
Joined: 23 Jun 20
Posts: 6
Credit: 277,966
RAC: 4,912
United Kingdom
Message 1859 - Posted: 24 Jun 2020, 19:54:39 UTC

I joined TN-Grid yesterday and I've happily processed 50+ WUs but sometime mid-afternoon today the resource share shown in BoincMgr changed to 0 and all of my processing WUs went into a wait state.

The resource share in my TN-Grid preferences is still showing as 100. I have tried changing it to 99 and doing an update and then changing it back to 100 and doing an update but within BoincMgr it remains at zero.

Is this a known problem? Could it be a problem in TN-Grid or do I need to take it to the Boinc forums?

mikey
Avatar
Send message
Joined: 28 Nov 16
Posts: 11
Credit: 10,374,026
RAC: 8,433
United States
Message 1860 - Posted: 24 Jun 2020, 20:29:36 UTC - in response to Message 1859.

I joined TN-Grid yesterday and I've happily processed 50+ WUs but sometime mid-afternoon today the resource share shown in BoincMgr changed to 0 and all of my processing WUs went into a wait state.

The resource share in my TN-Grid preferences is still showing as 100. I have tried changing it to 99 and doing an update and then changing it back to 100 and doing an update but within BoincMgr it remains at zero.

Is this a known problem? Could it be a problem in TN-Grid or do I need to take it to the Boinc forums?


Check the venue default, work, home or school to see if you are changing the one your pc is acutally in. Also make sure you are clicking the update button after you are making the changes.

If it's "waiting to run" what's running instead and what is the resource share for the other Project? It could be you owe crunching time to the other Project and it is giving it what your settings say to do. Resources Share is a daily resourcse share setting, or it tries to be anyway, so if you have 100 set for TN-Grid and 50 for another Project then 50% of the time the other Project will be crunching.

This is exactly why alot of people have multiple pc's, so they can crunch one project on each pc, or blitz thru the workunits on a single project to get a new or better badge.

(Ryle)
Send message
Joined: 13 Aug 19
Posts: 1
Credit: 1,446,308
RAC: 7,732
Denmark
Message 1861 - Posted: 24 Jun 2020, 20:33:15 UTC

Hi Bryn,
Or did you set resource share to zero in BAM via BoincStats for your host?
I think it overrides TN-Grid's setting.

Bryn Mawr
Send message
Joined: 23 Jun 20
Posts: 6
Credit: 277,966
RAC: 4,912
United Kingdom
Message 1863 - Posted: 24 Jun 2020, 21:06:48 UTC - in response to Message 1861.
Last modified: 24 Jun 2020, 21:19:21 UTC

Hi Bryn,
Or did you set resource share to zero in BAM via BoincStats for your host?
I think it overrides TN-Grid's setting.


Going through the event log it changed sometime after 19:00 which is when it completed a task. That computer contacted BAM at 15:41 then 21:41 and I had made no changes between those times so I don't see how it could be BAM related. I will, however, check and report back.

ETA: No, BAM is showing TN-Grid with a report share of 100. I've just changed it to 99 to see if that percolates down.

ETA2: OK, there are two places within BAM that hold the resource share, one at the project level and another at the host level within project. The first was 100 but the second was 0. I've changed the second to 100 and done both a project update and a resync with BAM from BoincMgr but with no effect.

ETA3: I've checked the config files within Boinc Client and the Account_***_XML file for TN-Grid holds a value of 100 so I'm coming to the conclusion that it's a Boinc problem so I'll ask there.

Bryn Mawr
Send message
Joined: 23 Jun 20
Posts: 6
Credit: 277,966
RAC: 4,912
United Kingdom
Message 1864 - Posted: 24 Jun 2020, 21:31:06 UTC - in response to Message 1860.
Last modified: 24 Jun 2020, 21:32:43 UTC

I joined TN-Grid yesterday and I've happily processed 50+ WUs but sometime mid-afternoon today the resource share shown in BoincMgr changed to 0 and all of my processing WUs went into a wait state.

The resource share in my TN-Grid preferences is still showing as 100. I have tried changing it to 99 and doing an update and then changing it back to 100 and doing an update but within BoincMgr it remains at zero.

Is this a known problem? Could it be a problem in TN-Grid or do I need to take it to the Boinc forums?


Check the venue default, work, home or school to see if you are changing the one your pc is acutally in. Also make sure you are clicking the update button after you are making the changes.

If it's "waiting to run" what's running instead and what is the resource share for the other Project? It could be you owe crunching time to the other Project and it is giving it what your settings say to do. Resources Share is a daily resourcse share setting, or it tries to be anyway, so if you have 100 set for TN-Grid and 50 for another Project then 50% of the time the other Project will be crunching.

This is exactly why alot of people have multiple pc's, so they can crunch one project on each pc, or blitz thru the workunits on a single project to get a new or better badge.


Good thinking, for some reason the set-up on my computer was pointing to School and there was no profile set up for that. I've created a profile and done an update but again no change.

My projects are Rosetta, WCG, Climate prediction and, now, TN-Grid. I run multiple projects on each PC to cater for the times when projects run out of work and I've added TN-Grid as two out of the three were running on empty. At the time it changed Boinc was running TN-Grid on all twelve cores as it saw zero work there as a debt and was trying to catch up.

Bryn Mawr
Send message
Joined: 23 Jun 20
Posts: 6
Credit: 277,966
RAC: 4,912
United Kingdom
Message 1866 - Posted: 25 Jun 2020, 9:25:27 UTC

OK, I’m still confused but the problem has resolved itself overnight with the resource share bein downloaded from TN-Grid default profile.

Why the delay I don’t know, it now updates immediately if I change it in TN-Grid and do update which it wasn’t yesterday.

Many thanks for the helpful suggestions made.

Bryn Mawr
Send message
Joined: 23 Jun 20
Posts: 6
Credit: 277,966
RAC: 4,912
United Kingdom
Message 1867 - Posted: 25 Jun 2020, 15:47:40 UTC - in response to Message 1866.

OK, I’m still confused but the problem has resolved itself overnight with the resource share being downloaded from TN-Grid default profile.

Why the delay I don’t know, it now updates immediately if I change it in TN-Grid and do update which it wasn’t yesterday.

Many thanks for the helpful suggestions made.




More confusion, the resource share has changed again, this time taking the value from the BAM host within project level. It would appear that sync with account manager does not update this value but the 6 hourly refresh does.


Post to thread

Message boards : Number crunching : Resource Share Problem


Main page · Your account · Message boards


Copyright © 2020 CNR-TN & UniTN