Posts by Buro87 [Lombardia]
log in
1) Message boards : Number crunching : sse2 vs avx (Message 1288)
Posted 3 May 2018 by Buro87 [Lombardia]
http://gene.disi.unitn.it/test/show_host_detail.php?hostid=13464


if you click on "Application details" you can see that: the sse2 version is more profitable for you (3,40 GFlops) against avx (2,83 GFlops)
this is the reason why you recieve much more sse2 wus
2) Message boards : Number crunching : Server Status - No Work Available (Message 1275)
Posted 3 Apr 2018 by Buro87 [Lombardia]
This afternoon we will have a meeting to discuss various issues, among them the new big experiment and the efficiency of the system. I will update you all after that.

I have just generated a few workunits related to the new experiment, just a test, for the moment, checking if everything will work well.


Hi Valter, any updates from the new project?
3) Message boards : Number crunching : Server Status - No Work Available (Message 1272)
Posted 20 Mar 2018 by Buro87 [Lombardia]
This afternoon we will have a meeting to discuss various issues, among them the new big experiment and the efficiency of the system. I will update you all after that.

I have just generated a few workunits related to the new experiment, just a test, for the moment, checking if everything will work well.


i have done 4 of them. around 2h 45min on ryzen 5-1600
4) Message boards : Number crunching : Server Status - No Work Available (Message 1269)
Posted 13 Mar 2018 by Buro87 [Lombardia]
We are back to zero work units available for down load. Since the Admin has not responded on this thread I will try to send a PM to him.

Bill F
Dallas TX


he has answered in the post before your's
5) Message boards : News : Another experiment on E. coli (Message 1256)
Posted 3 Feb 2018 by Buro87 [Lombardia]
Why don't you try to overclock your Ryzen CPUs? With the stock cooler you can do it to 3.6-3.7 GHz without overheat it. I have a Ryzen 7 1700 at 3.9 GHz and it works perfectly.


My R7 1700 is runnig @ 2,7 GHz to save Energie.
Electricity is quiet expansive in Germany.
At this speed the R7 uses less than 50 watts.
@ 3.6 GHz it would be around 90 watts or more. :)



You just set cpu multiplier to x27? Or you have add an undervolt?

I will try to set my r5-1600 from 3.4ghz (1,07v vcore) to 3-3.1ghz
I also test if CPU stay less time waiting for memory
6) Message boards : News : Another experiment on E. coli (Message 1252)
Posted 31 Jan 2018 by Buro87 [Lombardia]
However, 0:40 ~ 4:00 hours for every WU.
AMD Ryzen 7 1700 at 3.9 GHz
RAM 2x8GB 3200 MHz CL16


My bottleneck is ram bandwidth because i have only 1 stick

as explained by Daniel at the end of this thread
http://gene.disi.unitn.it/test/forum_thread.php?id=135#1229
in my case, overclock on CPU is not so good
7) Message boards : News : Another experiment on E. coli (Message 1247)
Posted 20 Jan 2018 by Buro87 [Lombardia]
4h 45min on my ryzen 5 1600 stock, SMT on (12WU) ram at 2933mhz
8) Message boards : News : Another experiment on E. coli (Message 1243)
Posted 18 Jan 2018 by Buro87 [Lombardia]
These are running about 5 hours on my Win 10 4770K @ 4GHz...



as explained by Danien at the end of this thread
http://gene.disi.unitn.it/test/forum_thread.php?id=135#1229

with TN-Grid app, ram frequency is more important than cpu speed
9) Message boards : Number crunching : Optimization (Message 1226)
Posted 13 Dec 2017 by Buro87 [Lombardia]

i have 1x8GB 2666mhz c16,...


OK, that´s just single channel and slows down the system as well.
With two RAM-Sticks you would use dual channel with a much wider bandwith.



when ram price will drop to a "fair price" i'll add another stick, only for dual channel bandwidth, because TN-grid Wus are no so big (Win10 + 12Wus take only 3GB of ram)
10) Message boards : Number crunching : Optimization (Message 1225)
Posted 13 Dec 2017 by Buro87 [Lombardia]
How is your RAM-Speed?
On my R7 it makes a big differens between 2.133 MHz an 3.066 Mht (up to 30 minutes)


i have 1x8GB 2666mhz c16, maybe i try to overclock it

i have undersood the "problem": if i set CPU usage at 50% (or turning off SMT) the 6 simultaneus WUs take around 2400s to complete:mysteri solved

I don't understand why WUs don't speedup when cpu is at 3.8ghz

TN-Grid app is very memory-intensive. One person from my team wrote that on his Xeon 14c/28t (I do not know exact model, probably it is E5-2683 v3) 4 TN-Grid WUs consumed all available memory bandwidth. So when you hit this limit, increasing CPU speed will not help, it will faster wait for memory ;)

Edit: when you set CPU usage to 50%, app will be able to get data from memory faster (less apps will compete for the same limited bandwidth), every app instance could use more cache (additionally helping with loading data), plus CPU resources will not be shared between two apps (SMT/HT does not improve speed twice, usually it is much less).

If you want to improve speeds, use fastest possible memory, and overclock it if possible.


tanks Daniel

Thanks Daniel
how i can see memory bandwidth usage?
just for test i tried to run ram at 2133mhz and a Wu (with 12 thread) take around 4300s
Setting ram at 2933mhz Wu drops to 3700s
11) Message boards : Number crunching : Optimization (Message 1222)
Posted 11 Dec 2017 by Buro87 [Lombardia]
How is your RAM-Speed?
On my R7 it makes a big differens between 2.133 MHz an 3.066 Mht (up to 30 minutes)


i have 1x8GB 2666mhz c16, maybe i try to overclock it

i have undersood the "problem": if i set CPU usage at 50% (or turning off SMT) the 6 simultaneus WUs take around 2400s to complete:mysteri solved

I don't understand why WUs don't speedup when cpu is at 3.8ghz
12) Message boards : Number crunching : Optimization (Message 1220)
Posted 11 Dec 2017 by Buro87 [Lombardia]
Hi, i'm trying my new r5-1600 stock (3.4ghz all core) and i've saw a big difference in CPU with other r5-1600
My task: around 3700s
http://gene.disi.unitn.it/test/results.php?userid=512&offset=0&show_names=0&state=4&appid=
others r5-1600: around 2300-2700s
http://gene.disi.unitn.it/test/results.php?hostid=16885&offset=0&show_names=0&state=4&appid=
http://gene.disi.unitn.it/test/results.php?hostid=18494&offset=0&show_names=0&state=4&appid=

it's almost 40% difference, running the same app (v1.10)
i tried to overclock to 3.8ghz but Cpu time is almost the same
how can speedup my WUs?
thanks
13) Message boards : Number crunching : Badges (all of them) (Message 1168)
Posted 26 Oct 2017 by Buro87 [Lombardia]
Maybe a 25000cr badge should be better. a "Wood Bedge" for example
14) Message boards : Number crunching : Optimization (Message 1156)
Posted 24 Oct 2017 by Buro87 [Lombardia]
I saw many users are running v 1.03
is faster than (Opti v.1.2) 1.02 developed by Daniel?


sorry, my bad. the v1.03 is only for linux
15) Message boards : Number crunching : Optimization (Message 1149)
Posted 23 Oct 2017 by Buro87 [Lombardia]
I saw many users are running v 1.03
is faster than (Opti v.1.2) 1.02 developed by Daniel?
16) Message boards : News : Vitis vinifera: new dataset (Message 1124)
Posted 14 Oct 2017 by Buro87 [Lombardia]
In the "Science Status" pae ihave saw that we complete around 310 genes a day.
just for curiosity, how many WU form 1 gene?
17) Message boards : Number crunching : Optimization (Message 1063)
Posted 12 May 2017 by Buro87 [Lombardia]
hi Daniel i have a problem installing the app on the i5-6400 pc
in 10 days (around 500wu completed) i haave recived equal number of sse and avx WU. no fma wu
both sse and avx standard app are around 1250s so i will try sse first

i copy both pc.exe and app_info.xml in C:\Users\All Users\BOINC\projects\gene.disi.unitn.it_test\ but it doesn't work
i have todelete some existing file first?
18) Message boards : Number crunching : Optimization (Message 1061)
Posted 4 May 2017 by Buro87 [Lombardia]
Hi daniel, i have a question for you

on my i5-6400 win7 64bit i recieve both avx an sse2 WU
if i want instal your optimization v1.2 which version i need to copy in the project folder?
- TN-Grid.windows-x86-64-avx-v1.2
- TN-Grid.windows-x86-64-sse2-v1.2
can i install both?

Your CPU also supports FMA instructions, so you can also try FMA app version: http://www.cpu-world.com/CPUs/Core_i5/Intel-Core%20i5-6400.html. In general FMA app version should be faster than AVX, which is faster than SSE one. However on some CPUs FMA versions for some reason is a bit slower than AVX one, so please try both.

It is possible to install few versions, but you would have to rename pc.exe files and modify app_info.xml to specify all app versions with proper plan classes. Files prepared by me are configured to run single app version only.


ok i will try fma app too. i use the i5-6400 since yesterday (60 wu completed) and i haven't recieve any fma WU
i will try all 3 apps from tomorrow

for now, both sse2 and avx standard app are between 1220 - 1290s cpu time
19) Message boards : Number crunching : Optimization (Message 1059)
Posted 4 May 2017 by Buro87 [Lombardia]
Hi daniel, i have a question for you

on my i5-6400 win7 64bit i recieve both avx an sse2 WU
if i want instal your optimization v1.2 which version i need to copy in the project folder?
- TN-Grid.windows-x86-64-avx-v1.2
- TN-Grid.windows-x86-64-sse2-v1.2
can i install both?
20) Message boards : Number crunching : Optimization (Message 1040)
Posted 9 Apr 2017 by Buro87 [Lombardia]
I have copleted WU with the new aptimization
i5-750
windows7 64bit SSE
before 2480-2550s CPU time
now 2260-2280s CPU time
a 9-12% gain
good job


Next 20

Main page · Your account · Message boards


Copyright © 2018 CNR-TN & UniTN