SSL Certificate
log in

Advanced search

Message boards : News : SSL Certificate

Author Message
Profile valterc
Project administrator
Project tester
Send message
Joined: 30 Oct 13
Posts: 320
Credit: 16,266,305
RAC: 4,439
Italy
Message 675 - Posted: 21 Dec 2016, 11:40:22 UTC
Last modified: 21 Dec 2016, 11:40:56 UTC

In the next days I will install a SSL certificate, thus allowing secure communications via the https protocol. You may notice it when your boinc client will start complaining about it, saying something like "This project is using an old URL. When convenient...". You may simply ignore this message or detach from the project and re-attach using the new https url (it will be the usual one, just with https:// at the beginning).
Please do this when your queue is empty.

Profile bcavnaugh
Avatar
Send message
Joined: 22 Nov 16
Posts: 5
Credit: 1,209,001
RAC: 124
United States
Message 679 - Posted: 21 Dec 2016, 18:31:22 UTC - in response to Message 675.

Will you also update BAM!
One issues I see all over BOINC Projects is when they make a change like this they do not contact BAM! to have them change their info so that it updates all the Clients that use BAM!.
Thank you
____________
Crunching@EVGA The Number One Team in the BOINC Community.
Folding@EVGA The Number One Team in the Folding@Home Community.

DigiK-oz
Send message
Joined: 7 Nov 16
Posts: 5
Credit: 1,490,894
RAC: 809
Netherlands
Message 680 - Posted: 22 Dec 2016, 8:39:13 UTC
Last modified: 22 Dec 2016, 8:43:51 UTC

Seems the certificate is in place already, and HTTPS connections work (?). If that is the case, might wanna change the "join TNGRID" text on your main page as that still states http:// :)

Profile valterc
Project administrator
Project tester
Send message
Joined: 30 Oct 13
Posts: 320
Credit: 16,266,305
RAC: 4,439
Italy
Message 681 - Posted: 22 Dec 2016, 10:37:57 UTC - in response to Message 680.
Last modified: 22 Dec 2016, 10:38:15 UTC

Seems the certificate is in place already, and HTTPS connections work (?). If that is the case, might wanna change the "join TNGRID" text on your main page as that still states http:// :)

Yes, I installed the certificate, but I have a few issue to solve (if you connect via https the home page still contains http references, throwing a little warning on Firefox), I guess that in order to fix this I have to upgrade the server code to the latest one. I will try to do this as soon as possible.
Anyway, thank you for the hint.

Dr Who Fan
Send message
Joined: 12 Oct 16
Posts: 2
Credit: 56,707
RAC: 9
United States
Message 682 - Posted: 22 Dec 2016, 14:31:10 UTC - in response to Message 679.

Will you also update BAM!
One issues I see all over BOINC Projects is when they make a change like this they do not contact BAM! to have them change their info so that it updates all the Clients that use BAM!.
Thank you

The project owner/admin have NO control over what is in BAM!
You need to ask Willy at BOINCSTATS to change the code in BAM! once it is fully implemented here at TNGrid by posting a message in the forum titled "BAM! Bug Report"
____________

Erkan Yilmaz
Send message
Joined: 24 Dec 16
Posts: 16
Credit: 80,038
RAC: 8
Germany
Message 708 - Posted: 2 Jan 2017, 14:14:36 UTC - in response to Message 675.
Last modified: 2 Jan 2017, 14:22:05 UTC

When I go to (A) my browser tells me: (B). Need to check if this is due to some browser cache ?


BUT: the SSL quality is quite superb: A (C). Thank you!



(A) https://gene.disi.unitn.it/test/

(B)
Mixed Content: The page at 'https://gene.disi.unitn.it/test/' was loaded over HTTPS, but requested an insecure image 'http://gene.disi.unitn.it/test/user_profile/images/106_sm.jpg'. This content should also be served over HTTPS.

gene.disi.unitn.it/:89 Mixed Content: The page at 'https://gene.disi.unitn.it/test/' was loaded over HTTPS, but requested an insecure image 'http://gene.disi.unitn.it/test/img/head_20.png'. This content should also be served over HTTPS.


(C) https://www.ssllabs.com/ssltest/analyze.html?d=gene.disi.unitn.it

Profile valterc
Project administrator
Project tester
Send message
Joined: 30 Oct 13
Posts: 320
Credit: 16,266,305
RAC: 4,439
Italy
Message 709 - Posted: 2 Jan 2017, 14:52:19 UTC - in response to Message 708.

The mixed content problem should probably go away if I update the server php code to the latest one. ... But, you know, it's something that you have to do very carefully...


Post to thread

Message boards : News : SSL Certificate


Main page · Your account · Message boards


Copyright © 2017 CNR-TN & UniTN